FlutterWave Payment on Partial outage

Incident Report for Mista

Update

We are continuing to investigate this issue.
Posted Mar 16, 2021 - 07:03 UTC

Investigating

We have adentified an issue with Flutterwave Payment
you may use Momo or Bank as we conduct deep investigation on this issue
Posted Mar 15, 2021 - 22:50 UTC
This incident affects: Services (Dashboard).